summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-06 15:02:27 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-06 15:02:27 +0200
commit18bf40a087bbb9d671f9fcb9ff6e26b94ba02ffa (patch)
tree767b3e2554a87b720d4da84a7c46461fddc05ed4
parent85e5721421b7e8ee1cf6b76d34e892034e3c4f51 (diff)
downloadguix-18bf40a087bbb9d671f9fcb9ff6e26b94ba02ffa.tar.gz
gnu: gawk: Remove unneeded 'install-locale' phase.
* gnu/packages/gawk.scm (gawk)[arguments]: Remove now unneeded
  'install-locale' phase.
-rw-r--r--gnu/packages/gawk.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 425974f61e..6bfea34667 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -57,17 +57,7 @@
                                (string-append "### " match))))
                           '())))
 
-                (alist-cons-before
-                 'check 'install-locales
-                 (lambda _
-                   ;; A bunch of tests require the availability of a UTF-8
-                   ;; locale and otherwise fail.  Since UTF-8 locales are not
-                   ;; available during bootstrap, create one here.
-                   (setenv "GUIX_LOCPATH" (getcwd))
-                   (zero? (system* "localedef" "--no-archive"
-                                   "--prefix" (getcwd) "-i" "en_US"
-                                   "-f" "UTF-8" "./en_US.utf8")))
-                 %standard-phases))))
+                %standard-phases)))
    (inputs `(("libsigsegv" ,libsigsegv)
 
              ,@(if (%current-target-system)