summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:39:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:10 +0200
commit196dd9c2adaf72a5dfbf83de2632f344792b2212 (patch)
tree42f15e2d2e15b1a7e1bf140ecae66b957b8148dc
parentb16a1f98c9d8563c9e3ee7d0add7ed720e2f7074 (diff)
downloadguix-196dd9c2adaf72a5dfbf83de2632f344792b2212.tar.gz
gnu: Add texlive-physunits.
* gnu/packages/tex.scm (texlive-physunits): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 081284051c..989d088c8c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5454,6 +5454,28 @@ Modules of physics provide the following supports:
 @end itemize")
     (license license:lppl1.3c)))
 
+(define-public texlive-physunits
+  (package
+    (name "texlive-physunits")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/physunits/"
+                   "source/latex/physunits/"
+                   "tex/latex/physunits/")
+             (base32
+              "139qcg10879q17l84kqh8x1rzp8bgdcyd4iaxwgl4qlnrkg5rbl5")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/physunits")
+    (synopsis "Macros for commonly used physical units")
+    (description
+     "This package provides a collection of macros to simplify using physical units
+(e.g., @samp{m} for meters, @samp{J} for joules, etc.), especially in math
+mode.  All major SI units are included, as well as some @acronym{CGS,
+Centimetre–Gram–Second} units used in astronomy.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")