summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-11 21:35:54 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-12 08:31:13 -0400
commit19d7ccb6ce0d6688cb4a69aa58799cb0fe4e0d6b (patch)
treec8cb942e6041f12755fa95e0c2aa44ea9d83a0c2
parent15e6e7c8a0c12150966b10d60cb55560be51a0e4 (diff)
downloadguix-19d7ccb6ce0d6688cb4a69aa58799cb0fe4e0d6b.tar.gz
gnu: ruby-rubyzip: Re-instate all tests.
* gnu/packages/ruby.scm (ruby-rubyzip)
[arguments]: Do not patch ruby shebang in the patch-tests phase.
Remove the disable-problematic-tests phase.  Add the
unpatch-some-source-shebangs phase.
-rw-r--r--gnu/packages/ruby.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 377317a993..834c0dfbd4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3697,9 +3697,9 @@ Ruby Gems.")
                (("/usr/bin/zip") (which "zip")))))
          (add-after 'patch-source-shebangs 'unpatch-some-source-shebangs
            (lambda _
-             ;; The test compare zipped files with data test files; since the
+             ;; The tests compare zipped files with data test files; since the
              ;; zip files do not have their shebangs patched, the data files
-             ;; compared to their extracted version must also be left
+             ;; compared with their extracted version must also be left
              ;; un-patched.
              (substitute* (find-files "test/data" "\\.(txt|rb)$")
                (((which "ruby"))