summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-07-24 18:42:56 +0200
committerAndreas Enge <andreas@enge.fr>2016-07-24 18:42:56 +0200
commit1abdc167d3a602e3a35374762ac1ed4d7e9f0593 (patch)
tree9e1519d9302de4deab6b5730bcf5b9444cf1b5d2
parentfe7fa353201286ae1ad78511d5b5cd3fa8213b65 (diff)
parente03a51530450e85f88dd36ad459f06950eb906ea (diff)
downloadguix-1abdc167d3a602e3a35374762ac1ed4d7e9f0593.tar.gz
Merge branch 'master' into core-updates
-rw-r--r--gnu/packages/bioinformatics.scm64
1 files changed, 32 insertions, 32 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5cd92b8150..6065a0079b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1831,7 +1831,7 @@ similarity of community members.")
 (define-public fasttree
   (package
    (name "fasttree")
-   (version "2.1.8")
+   (version "2.1.9")
    (source (origin
              (method url-fetch)
              (uri (string-append
@@ -1839,7 +1839,7 @@ similarity of community members.")
                    version ".c"))
              (sha256
               (base32
-               "0dzqc9vr9iiiw21y159xfjl2z90vw0y7r4x6456pcaxiy5hd2wmi"))))
+               "0ljvvw8i1als1wbfzvrf15c3ii2vw9db20a259g6pzg34xyyb97k"))))
    (build-system gnu-build-system)
    (arguments
     `(#:tests? #f ; no "check" target
@@ -1848,37 +1848,37 @@ similarity of community members.")
         (delete 'unpack)
         (delete 'configure)
         (replace 'build
-                 (lambda* (#:key source #:allow-other-keys)
-                   (and (zero? (system* "gcc"
-                                        "-O3"
-                                        "-finline-functions"
-                                        "-funroll-loops"
-                                        "-Wall"
-                                        "-o"
-                                        "FastTree"
-                                        source
-                                        "-lm"))
-                        (zero? (system* "gcc"
-                                        "-DOPENMP"
-                                        "-fopenmp"
-                                        "-O3"
-                                        "-finline-functions"
-                                        "-funroll-loops"
-                                        "-Wall"
-                                        "-o"
-                                        "FastTreeMP"
-                                        source
-                                        "-lm")))))
+          (lambda* (#:key source #:allow-other-keys)
+            (and (zero? (system* "gcc"
+                                 "-O3"
+                                 "-finline-functions"
+                                 "-funroll-loops"
+                                 "-Wall"
+                                 "-o"
+                                 "FastTree"
+                                 source
+                                 "-lm"))
+                 (zero? (system* "gcc"
+                                 "-DOPENMP"
+                                 "-fopenmp"
+                                 "-O3"
+                                 "-finline-functions"
+                                 "-funroll-loops"
+                                 "-Wall"
+                                 "-o"
+                                 "FastTreeMP"
+                                 source
+                                 "-lm")))))
         (replace 'install
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   (let ((bin (string-append (assoc-ref outputs "out")
-                                             "/bin")))
-                     (mkdir-p bin)
-                     (copy-file "FastTree"
-                                (string-append bin "/FastTree"))
-                     (copy-file "FastTreeMP"
-                                (string-append bin "/FastTreeMP"))
-                     #t))))))
+          (lambda* (#:key outputs #:allow-other-keys)
+            (let ((bin (string-append (assoc-ref outputs "out")
+                                      "/bin")))
+              (mkdir-p bin)
+              (copy-file "FastTree"
+                         (string-append bin "/FastTree"))
+              (copy-file "FastTreeMP"
+                         (string-append bin "/FastTreeMP"))
+              #t))))))
    (home-page "http://www.microbesonline.org/fasttree")
    (synopsis "Infers approximately-maximum-likelihood phylogenetic trees")
    (description