summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:05 +0200
commit1ad285e80e71755f47b396a4603f1a1523769e49 (patch)
tree5e09a359a3fb64c942f09100ad05b4ef2147e825
parentc1e36460a45b57eaabf8eb4d34ddbf109b256eaf (diff)
downloadguix-1ad285e80e71755f47b396a4603f1a1523769e49.tar.gz
gnu: Add texlive-truncate.
* gnu/packages/tex.scm (texlive-truncate): New variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 383742887d..98a9cb79d2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98589,6 +98589,24 @@ transformations, together with a LaTeX @file{.fd} file and a package providing
 commands for the symbols use in mathematics.")
     (license license:lppl1.2+)))
 
+(define-public texlive-truncate
+  (package
+    (name "texlive-truncate")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/truncate/" "tex/latex/truncate/")
+             (base32
+              "1zxcn84lrl07cjiw4gzg2fnkriwfv8ziww5grbvfhffwqpaf8mgj")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/truncate")
+    (synopsis "Truncate text to a specified width")
+    (description
+     "The package will by default break at word boundaries, but package options are
+offered to permit breaks within words.")
+    (license license:public-domain)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar