summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:56 +0200
commit1b24f8a91da6682683a1f45043e6efe7c1e6e3d2 (patch)
treee59bda834a9a3324221a919fc811e9e138d31c05
parent9a2e3a25e63ee34afa6278be43ca9d705b850bee (diff)
downloadguix-1b24f8a91da6682683a1f45043e6efe7c1e6e3d2.tar.gz
gnu: Add texlive-thumbs.
* gnu/packages/tex.scm (texlive-thumbs): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c92a5a36b5..357c649c6f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98121,6 +98121,31 @@ through as if its contents were contiguous.")
      "This package places thumb marks in books, manuals and reference maunals.")
     (license license:gpl3+)))
 
+(define-public texlive-thumbs
+  (package
+    (name "texlive-thumbs")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/thumbs/" "source/latex/thumbs/"
+                   "tex/latex/thumbs/")
+             (base32
+              "0p7p9kg81b0zld25xfipjlv5dv9sc8mjq80kv15mkc4v2y41cdl2")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/thumbs")
+    (synopsis "Create thumb indexes")
+    (description
+     "The package puts running, customizable thumb marks in the outer margin,
+moving downward as the chapter number (or whatever shall be marked by the
+thumb marks) increases.  Additionally an overview page/table of thumb marks
+can be added automatically, which gives the names of the thumbed objects, the
+page where the object/thumb mark first appears, and the thumb mark itself at
+its correct position.  The thumb marks are useful for large documents (such as
+reference guides, anthologies, etc.), where a quick and easy way to find (for
+example) a chapter is needed.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar