summary refs log tree commit diff
diff options
context:
space:
mode:
authorPeter Polidoro <peter@polidoro.io>2022-04-06 15:21:14 -0400
committerLudovic Courtès <ludo@gnu.org>2022-04-29 18:07:17 +0200
commit1bb177d08401feb4370d6422f2c6fc746adc7c2a (patch)
tree6d09782b5a5c75a4b5470dc538043e465eb9bfa1
parent6ce8d9be438f9d16338232ebf03a4f749cc1ff4f (diff)
downloadguix-1bb177d08401feb4370d6422f2c6fc746adc7c2a.tar.gz
gnu: Add python-flatten-json.
* gnu/packages/python-xyz.scm (python-flatten-json): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f8e599a453..2bfe6745d9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29587,3 +29587,22 @@ and setting the color of terminal output, via HyDEV.")
 versions of MkDocs-powered docs to a Git branch.  It is suitable for deploying
 to Github via gh-pages.")
     (license license:bsd-3)))
+
+(define-public python-flatten-json
+  (package
+    (name "python-flatten-json")
+    (version "0.1.13")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "flatten_json" version))
+        (sha256
+          (base32 "007m28gfs7pmz2rqqjxpial6skzw26hrfi8vrdy9agi9x0rj6dgf"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-six))
+    (home-page "https://github.com/amirziai/flatten")
+    (synopsis "Flatten JSON objects")
+    (description
+     "The @code{flatten_json} Python library flattens the hierarchy in your
+object, which can be useful if you want to force your objects into a table.")
+    (license license:expat)))