summary refs log tree commit diff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:45:05 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:27:41 +0200
commit1c225fabd6c6b1a3876e30ed1443d8b0d1dce8d8 (patch)
treec6d93a9f02696318c4c79453224be443d75b93d9
parentd5c34f9b18087ee462512eed21e6d4a332f2235a (diff)
downloadguix-1c225fabd6c6b1a3876e30ed1443d8b0d1dce8d8.tar.gz
gnu: Add ghc-microlens.
* gnu/packages/haskell.scm (ghc-microlens): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7723eaa5ce..08e357a68e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9321,4 +9321,29 @@ typeclass, instances for base and transformers, and basic utility
 functions.")
     (license license:expat)))
 
+(define-public ghc-microlens
+  (package
+    (name "ghc-microlens")
+    (version "0.4.8.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "microlens-" version "/"
+                           "microlens-" version ".tar.gz"))
+       (sha256
+        (base32
+         "17qx2mbqdrlnkc3gxq8njbp7qw8nh51drmz6fc8khgj9bls5ni2k"))))
+    (build-system haskell-build-system)
+    (home-page
+     "https://github.com/aelve/microlens")
+    (synopsis "Provides a tiny lens Haskell library with no dependencies")
+    (description "This Haskell package provides a lens library, just like
+@code{ghc-lens}, but smaller.  It provides essential lenses and
+traversals (like @code{_1} and @code{_Just}), as well as ones which are simply
+nice to have (like @code{each}, @code{at}, and @code{ix}), and some
+combinators (like @code{failing} and @code{singular}), but everything else is
+stripped.  As the result, this package has no dependencies.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here