summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:43:31 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:12:15 +0100
commit1cef2c561f51acc309060855b963892ebf776c36 (patch)
treeb8ce7df8dbff3c1b0e0c181f7fa61c23b92d8995
parent571878854c90f3a0546dbaf1dd69223200ac5001 (diff)
downloadguix-1cef2c561f51acc309060855b963892ebf776c36.tar.gz
gnu: Remove ocaml4.07-fmt.
* gnu/packages/ocaml.scm (ocaml4.07-fmt): Remove variable.
(ocaml-fmt)[properties]: Remove variant.

Change-Id: I35d294d764a1e3fd8160a7da9cbd5cab9bea4660
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 0 insertions, 15 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 33340e95af..cc3e15ff9c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2363,27 +2363,12 @@ most of the POSIX and GNU conventions.")
                  #:phases
                  (modify-phases %standard-phases
                    (delete 'configure))))
-    (properties `((ocaml4.07-variant . ,(delay ocaml4.07-fmt))))
     (home-page "https://erratique.ch/software/fmt")
     (synopsis "OCaml Format pretty-printer combinators")
     (description "Fmt exposes combinators to devise Format pretty-printing
 functions.")
     (license license:isc)))
 
-(define-public ocaml4.07-fmt
-  (package-with-ocaml4.07
-    (package
-      (inherit ocaml-fmt)
-      (version "0.8.9")
-      (source (origin
-                (method url-fetch)
-                (uri (string-append "http://erratique.ch/software/fmt/releases/fmt-"
-                                    version ".tbz"))
-                (sha256
-                 (base32
-                  "0gkkkj4x678vxdda4xaw2dd44qjacavsvn5nx8gydfwah6pjbkxk"))))
-      (properties '()))))
-
 (define-public ocaml-astring
   (package
     (name "ocaml-astring")