summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-10-11 20:07:22 -0500
committerChristopher Baines <mail@cbaines.net>2022-12-12 20:39:41 +0000
commit1d160f41f5e973ea2bbbf8bc80d216b5d9b0974c (patch)
tree56dd22a6dd5c408fb6660422a83ee1aa64db4e62
parente4fd04fb92e2da769ca521eba877bbcd936f290e (diff)
downloadguix-1d160f41f5e973ea2bbbf8bc80d216b5d9b0974c.tar.gz
gnu: Add erlang-yamerl.
* gnu/packages/erlang.scm (erlang-yamerl): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/erlang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 90f290468b..cfada5a619 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -281,6 +281,28 @@ Mozilla's canonical set.")
 printing extending the io:format syntax to add colours.")
     (license license:expat)))
 
+(define-public erlang-yamerl
+  (package
+    (name "erlang-yamerl")
+    (version "0.10.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             ;; There are no tests included on Hex.
+             (url "https://github.com/yakaz/yamerl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0if8abgmispcfk7zhd0a5dndzwzbsmqrbyrm5shk375r2dbbwak6"))))
+    (build-system rebar-build-system)
+    (synopsis "YAML and JSON parser in pure Erlang")
+    (description
+     "Erlang application to parse YAML 1.1 and YAML 1.2 documents, as well as
+JSON documents.")
+    (home-page "https://hexdocs.pm/yamerl/")
+    (license license:bsd-2)))
+
 (define-public erlang-covertool
   (package
     (name "erlang-covertool")