summary refs log tree commit diff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-09-14 19:14:21 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-09-14 23:52:37 +0200
commit1d5f1a5462491bf877999525466fb83c55e7e66d (patch)
tree06fed15216fac181c0997e26328ed2a922f872e6
parentb2cc649999ed97b62517dcfb7cf21ee731c97487 (diff)
downloadguix-1d5f1a5462491bf877999525466fb83c55e7e66d.tar.gz
gnu: glib-next: Disable failing tests on the Hurd.
* gnu/packages/glib.scm (glib-next)[arguments]: In phase `disable-tests',
disable four extra failing tests when building on the Hurd.
-rw-r--r--gnu/packages/glib.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index e2a0bbdcdf..b5eb4602da 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -532,7 +532,21 @@ functions for strings and common data structures.")
                             (string-append "//" all "\n"))
                            (("^  g_assert_cmpfloat \\(elapsed, ==.*" all)
                             (string-append "//" all "\n"))))
-                       '())))))))
+                       '())
+              #$@(if (system-hurd?)
+                     '((with-directory-excursion "gio/tests"
+                         ;; FAIL
+                         (substitute* '("appmonitor.c"
+                                        "gdbus-server-auth.c"
+                                        "live-g-file.c"
+                                        "socket.c")
+                           (("return (g_test_run|session_bus_run)" all call)
+                            (string-append "return 0;// " call))
+                           ((" (ret|rtv|result) = (g_test_run|session_bus_run)"
+                             all var call)
+                            (string-append " " var " = 0;// " call))
+                           (("[ \t]*g_test_add_func.*;") ""))))
+                     '())))))))
     (native-inputs
      (modify-inputs (package-native-inputs glib)
        (append desktop-file-utils)))