summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-19 16:06:32 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-19 16:56:25 +0100
commit1d893c3a97457be5861f129d666d4a6b9c390a5a (patch)
treeec98687f4ce48782cd4d38b04a5afd60bdd565ff
parent71bc9d195a110e014b86c7738e63ecd4a4edaabd (diff)
downloadguix-1d893c3a97457be5861f129d666d4a6b9c390a5a.tar.gz
gnu: emacs-eglot: Update to 1.10.
* gnu/packages/emacs-xyz.scm (emacs-eglot): Update to 1.10.
[source]: Use GNU ELPA as upstream since the project as been merged into Emacs
and the GitHub repository is no longer up-to-date.
[arguments]: Remove tests, which do not exist in the tarball.
[propagated-inputs]: Add EMACS-EXTERNAL-COMPLETION, EMACS-SEQ, EMACS-XREF.
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 11 insertions, 15 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 10b7229878..5cd518c5c4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17050,27 +17050,23 @@ Emacs.")
 (define-public emacs-eglot
   (package
     (name "emacs-eglot")
-    (version "1.9")
+    (version "1.10")
     (source
      (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/joaotavora/eglot")
-             (commit version)))
-       (file-name (git-file-name name version))
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/eglot-" version
+                           ".tar"))
        (sha256
         (base32
-         "030837yak24ymjawsfr1hgyfdjy3k30ld1ca0cgnrxhgxc7p8hwv"))))
+         "0iw1jnfsjd2yq73ic3cld8m51wyxdwn3kjv9ala28krvsvb4h3y4"))))
     (build-system emacs-build-system)
-    (arguments
-     (list
-      #:tests? #t
-      #:test-command #~(list "emacs" "--batch"
-                             "-l" "eglot.el"
-                             "-l" "eglot-tests.el"
-                             "-f" "ert-run-tests-batch-and-exit")))
     (propagated-inputs
-     (list emacs-eldoc emacs-jsonrpc emacs-project))
+     (list emacs-external-completion
+           emacs-eldoc
+           emacs-jsonrpc
+           emacs-project
+           emacs-seq
+           emacs-xref))
     (home-page "https://github.com/joaotavora/eglot")
     (synopsis "Client for Language Server Protocol (LSP) servers")
     (description