summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-23 22:32:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:58:11 +0200
commit2028830f0bc84ce469f26abe3e84512b5fbefac4 (patch)
treeafa98e472a15a90b0989085a71c35246ebc77076
parent49953e30fb1d0f1ab1c0de81e9bc8c89c10ebe02 (diff)
downloadguix-2028830f0bc84ce469f26abe3e84512b5fbefac4.tar.gz
gnu: rust-glob-0.3: Update to 0.3.1.
* gnu/packages/crates-io.scm (rust-glob-0.3): Update to 0.3.1.
[arguments]: Don't skip tests. Add cargo-test-flags to skip select
tests.
[cargo-development-inputs]: Add rust-doc-comment-0.3.
[home-page]: Update to new home-page.
-rw-r--r--gnu/packages/crates-io.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 51d5b5c2b0..266358bdf7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -29868,7 +29868,7 @@ OpenGL's old and error-prone API.")
 (define-public rust-glob-0.3
   (package
     (name "rust-glob")
-    (version "0.3.0")
+    (version "0.3.1")
     (source
       (origin
         (method url-fetch)
@@ -29876,13 +29876,16 @@ OpenGL's old and error-prone API.")
         (file-name (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "0x25wfr7vg3mzxc9x05dcphvd3nwlcmbnxrvwcvrrdwplcrrk4cv"))))
+          "16zca52nglanv23q5qrwd5jinw3d3as5ylya6y1pbx47vkxvrynj"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:tests? #f
+     `(#:cargo-test-flags
+       '("--release" "--"
+         "--skip=test::test_iteration_errors")
        #:cargo-development-inputs
-       (("rust-tempdir" ,rust-tempdir-0.3))))
-    (home-page "https://github.com/rust-lang-nursery/glob")
+       (("rust-doc-comment" ,rust-doc-comment-0.3)
+        ("rust-tempdir" ,rust-tempdir-0.3))))
+    (home-page "https://github.com/rust-lang/glob")
     (synopsis "Match file paths against Unix shell style patterns")
     (description
      "This package provides support for matching file paths against Unix