summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-14 10:16:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-14 20:43:31 +0200
commit2051be4f4cd526fb445e826d655afa40f8f4a7e5 (patch)
tree5c95c3c96f48014b41a267e90c3461d222c2ca15
parentf58e491fb837ae4344689c1cefdc1b6e582c3015 (diff)
downloadguix-2051be4f4cd526fb445e826d655afa40f8f4a7e5.tar.gz
gnu: gemma: Enable tests.
* gnu/packages/bioinformatics.scm (gemma)[source]: Add snippet to remove
bundled sources.
[native-inputs]: Add catch-framework2-1, perl, shunit2, which.
[arguments]: Don't disable tests. Override 'check phase.
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 70696c189a..84a9a4d208 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3572,12 +3572,22 @@ comment or quality sections.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1p8a7kkfn1mmrg017aziy544aha8i9h6wd1x2dk3w2794wl33qb7"))))
+                "1p8a7kkfn1mmrg017aziy544aha8i9h6wd1x2dk3w2794wl33qb7"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  (delete-file-recursively "contrib")
+                  #t))))
     (build-system gnu-build-system)
     (inputs
      `(("gsl" ,gsl)
        ("openblas" ,openblas)
        ("zlib" ,zlib)))
+    (native-inputs
+     `(("catch" ,catch-framework2-1)
+       ("perl" ,perl)
+       ("shunit2" ,shunit2)
+       ("which" ,which)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -3589,12 +3599,18 @@ comment or quality sections.")
                (("/usr/local/opt/openblas")
                 (assoc-ref inputs "openblas")))
              #t))
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               ;; 'make slow-check' expects shunit2-2.0.3.
+               (with-directory-excursion "test"
+                 (invoke "./test_suite.sh"))
+               #t)))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (install-file "bin/gemma"
                            (string-append (assoc-ref outputs "out") "/bin"))
-             #t)))
-       #:tests? #f)) ; no tests included yet
+             #t)))))
     (home-page "https://github.com/genetics-statistics/GEMMA")
     (synopsis "Tool for genome-wide efficient mixed model association")
     (description