summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 22:47:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:46 +0200
commit21dbe0812d5522bc5be85416ab634391d9266af7 (patch)
treeb394bb0d028c6fe10fa764f1582c321bffc15574
parent8ef25d0a632d35d7b5fa1e944eae4374faa318fe (diff)
downloadguix-21dbe0812d5522bc5be85416ab634391d9266af7.tar.gz
gnu: texlive-pdftexcmds: Refresh package definition.
* gnu/packages/tex.scm (texlive-pdftexcmds): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 19 insertions, 23 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9a1a9edb8d..ef8335f7f5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5633,30 +5633,26 @@ used to write the verbatim text to a file.")
     (license license:lppl1.3+)))
 
 (define-public texlive-pdftexcmds
-  (let ((template (simple-texlive-package
-                   "texlive-pdftexcmds"
-                   (list "doc/generic/pdftexcmds/"
-                         "source/generic/pdftexcmds/"
-                         "tex/generic/pdftexcmds/")
-                   (base32
-                    "0gad1vi0r5xw7gyj1cb2cp58j4dqrw4awcfxmfrna9xbz91g4sn9"))))
-    (package
-      (inherit template)
-      (outputs '("out" "doc"))
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ '())
-          "generic/pdftexcmds")
-         ((#:build-targets _ '())
-          #~(list "pdftexcmds.dtx"))))
-      (propagated-inputs
-       (list texlive-iftex texlive-infwarerr texlive-ltxcmds))
-      (home-page "https://www.ctan.org/pkg/pdftexcmds")
-      (synopsis "LuaTeX support for pdfTeX utility functions")
-      (description
-       "This package makes a number of utility functions from pdfTeX
+  (package
+    (name "texlive-pdftexcmds")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pdftexcmds/"
+                   "source/generic/pdftexcmds/"
+                   "tex/generic/pdftexcmds/")
+             (base32
+              "0gad1vi0r5xw7gyj1cb2cp58j4dqrw4awcfxmfrna9xbz91g4sn9")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-iftex texlive-infwarerr texlive-ltxcmds))
+    (home-page "https://www.ctan.org/pkg/pdftexcmds")
+    (synopsis "LuaTeX support for pdfTeX utility functions")
+    (description
+     "This package makes a number of utility functions from pdfTeX
 available for LuaTeX by reimplementing them using Lua.")
-      (license license:lppl1.3c+))))
+    (license license:lppl1.3c+)))
 
 (define-deprecated-package texlive-latex-pdftexcmds texlive-pdftexcmds)