summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-06-12 22:53:22 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-13 19:16:14 +0200
commit221a104248c3248459cbc849f482a429f83ca3d7 (patch)
treeac9bd37013b1bd035928485c4e084c7fc55b5e84
parent1eec6b0c01700e96ca7acdd5c1651167409de66b (diff)
downloadguix-221a104248c3248459cbc849f482a429f83ca3d7.tar.gz
gnu: perf: Restore use of dependencies.
* gnu/packages/linux.scm (perf)[arguments]: Remove C_INCLUDE_PATH from
 #:make-flags.  It is no longer needed since the switch to C_INCLUDE_PATH
in 2073b55e6b964cb8ca15e8c74cb32dac00f05f0d and would prevent
dependencies from being found.
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 0 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0d7f60ca82..ff8c277f95 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3711,11 +3711,6 @@ in a digital read-out.")
              #t)))
        #:make-flags (list (string-append "prefix="
                                          (assoc-ref %outputs "out"))
-                          ;; Make sure the kernel headers are treated as system
-                          ;; headers to suppress warnings from those.
-                          (string-append "C_INCLUDE_PATH="
-                                         (assoc-ref %build-inputs "kernel-headers")
-                                         "/include")
                           "WERROR=0"
 
                           ;; By default, 'config/Makefile' uses lib64 on