summary refs log tree commit diff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-06-25 23:36:48 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-07-26 12:27:03 +0300
commit22257dc70eddb04268f2b95d4b30985c7365a812 (patch)
tree8858e5816e83cd3fea4dfa43debdf2f5e07bc4a2
parent9d36948c548c5cf41f2befbf940b0c0d3c5f8467 (diff)
downloadguix-22257dc70eddb04268f2b95d4b30985c7365a812.tar.gz
gnu: Add emacs-org-generate.
* gnu/packages/emacs-xyz.scm (emacs-org-generate): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3954d22393..95a8c11e9b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23846,6 +23846,35 @@ as a plug-and-play solution for anyone already using Org mode for their
 personal wiki.")
     (license license:gpl3+)))
 
+(define-public emacs-org-generate
+  (package
+    (name "emacs-org-generate")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/conao3/org-generate.el.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0z2frp5mn3lp2xskwanw2rncrwa50x3aphy87vfxmhx4fqlqrzy8"))))
+    (inputs
+     `(("emacs-cort" ,emacs-cort))) ;tests suite
+    (propagated-inputs
+     `(("emacs-mustache" ,emacs-mustache)))
+    (arguments
+     `(#:tests? #t
+       #:test-command '("emacs" "--batch" "--quick"
+                        "--directory=." "--load=org-generate-tests.el"
+                        "--funcall=cort-test-run")))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/conao3/org-generate.el")
+    (synopsis "Generate template files and folders from Org document")
+    (description "This package allows to generate files and folders from Emacs
+org-mode templates.")
+    (license license:gpl3+)))
+
 (define-public emacs-uml-mode
   ;; Package has no release.  Version is extracted from "Version:" keyword in
   ;; main file.