summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-07 13:07:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-07 13:07:46 +0100
commit224d1c5818ef8342cb9ae0090adff0eb743049c8 (patch)
tree22bf6a345444c7dced880bf212e956c80abb98f3
parented15986a32c304133c20a75d12b8fe14b441250e (diff)
downloadguix-224d1c5818ef8342cb9ae0090adff0eb743049c8.tar.gz
gnu: python-dask: Update to 2021.11.2.
* gnu/packages/python-xyz.scm (python-dask): Update to 2021.11.2.
[source]: Fetch from github.
[arguments]: Remove phase 'disable-broken-tests.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 70bc458d67..7fb0a8f0bd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22745,24 +22745,20 @@ decisions with any given backend.")
 (define-public python-dask
   (package
     (name "python-dask")
-    (version "2021.9.1")
+    (version "2021.11.2")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "dask" version))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dask/dask/")
+             (commit "5a8275dd53193b47457cdfadc0e2356ea3eb6ccd")))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0p6nd8wi30l29g5hdwk0453w6fxg4zvxq1y1ix0fa2f8rbr2n7z1"))))
+        (base32 "0h8w7c03mn6s2mmwbqd2sqay3k4vaqiwlsbvliziggw28042zfw2"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'disable-broken-tests
-           (lambda _
-             ;; This test is marked as xfail when pytest-xdist is used.
-             (substitute* "dask/tests/test_threaded.py"
-               (("def test_interrupt\\(\\)" m)
-                (string-append "@pytest.mark.skip(reason=\"Disabled by Guix\")\n"
-                               m)))))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests? (invoke "pytest" "-vv")))))))