summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Yamashita <kei@openmailbox.org>2016-05-10 16:56:42 -0400
committerLudovic Courtès <ludo@gnu.org>2016-05-11 15:46:42 +0200
commit22c161d0a881bd86f02494c5512ee6310d326b4d (patch)
treec580bbe53ff14354729a9963f380653aff0d93c4
parent1aaf116d3158bf822d1da1b0f17b48a064bb8dd1 (diff)
downloadguix-22c161d0a881bd86f02494c5512ee6310d326b4d.tar.gz
gnu: libical: Correct zoneinfo search path.
* gnu/packages/calendar.scm (libical)[arguments]: substitute FHS-compliant
zoneinfo folders with location of tzdata's zoneinfo folder.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/calendar.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 5ef5ec9271..5ddd358607 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
 ;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Kei Yamashita <kei@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -47,11 +48,23 @@
                 "14lmjj63zyx88rf1z71l0v9ms4c2vpdhmixksjjxgywp5p2f7708"))))
     (build-system cmake-build-system)
     (arguments
-     '(#:tests? #f)) ; test suite appears broken
+     '(#:tests? #f ; test suite appears broken
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'patch-paths
+           (lambda _
+             (let ((tzdata (assoc-ref %build-inputs "tzdata")))
+               (substitute* "src/libical/icaltz-util.c"
+                 (("char \\*search_paths \\[\\] =.*$")
+                  (string-append
+                   "char *search_paths [] = "
+                   "{\"" tzdata "/share/zoneinfo\"};\n"))))
+             #t)))))
     (native-inputs
      `(("perl" ,perl)))
     (inputs
-     `(("icu4c" ,icu4c)))
+     `(("icu4c" ,icu4c)
+       ("tzdata" ,tzdata)))
     (home-page "https://libical.github.io/libical/")
     (synopsis "iCalendar protocols and data formats implementation")
     (description