summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-01-16 15:48:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-01-16 15:50:51 +0100
commit2309ed6862c51a4dad7aa1d37e34dcfce125e56b (patch)
treeca1d0c0043d6c44e278a64f1786b9c549dc5ecdf
parente90cf6c14a32472f013959f0b79b80888e6fa35c (diff)
downloadguix-2309ed6862c51a4dad7aa1d37e34dcfce125e56b.tar.gz
gnu: samtools-0.1: Adapt to changes in "samtools" variable.
* gnu/packages/bioinformatics.scm (samtools-0.1)[arguments]: Add
  "LIBCURSES" make flag; delete "configure" phase; disable tests outside
  of "substitute-keyword-arguments".
-rw-r--r--gnu/packages/bioinformatics.scm27
1 files changed, 15 insertions, 12 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3cabb9f528..314d0ad322 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2456,18 +2456,21 @@ viewer.")
        (sha256
         (base32 "1m33xsfwz0s8qi45lylagfllqg7fphf4dr0780rsvw75av9wk06h"))))
     (arguments
-     (substitute-keyword-arguments (package-arguments samtools)
-       ((#:tests? tests) #f) ;no "check" target
-       ((#:phases phases)
-        `(modify-phases ,phases
-           (replace 'install
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (let ((bin (string-append
-                                  (assoc-ref outputs "out") "/bin")))
-                        (mkdir-p bin)
-                        (copy-file "samtools"
-                                   (string-append bin "/samtools")))))
-           (delete 'patch-tests)))))))
+     `(#:tests? #f ;no "check" target
+       ,@(substitute-keyword-arguments (package-arguments samtools)
+           ((#:make-flags flags)
+            `(cons "LIBCURSES=-lncurses" ,flags))
+           ((#:phases phases)
+            `(modify-phases ,phases
+               (replace 'install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let ((bin (string-append
+                               (assoc-ref outputs "out") "/bin")))
+                     (mkdir-p bin)
+                     (copy-file "samtools"
+                                (string-append bin "/samtools")))))
+               (delete 'patch-tests)
+               (delete 'configure))))))))
 
 (define-public mosaik
   (let ((commit "5c25216d"))