summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 22:16:11 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:06 +0000
commit232ed89d4371de1d79b638cb2dbe82b239c90a75 (patch)
tree91b147fe9d501231282146485f9b085add503894
parent8882af2572de94b93cce3be6ebccf0bee51f8ee1 (diff)
downloadguix-232ed89d4371de1d79b638cb2dbe82b239c90a75.tar.gz
gnu: go-github.com-smartystreets-goconvey: Move to (gnu packages golang-check).
* gnu/packages/check.scm (go-github.com-smartystreets-goconvey): Move
from here ...
* gnu/packages/golang-check.scm: ... to here.

Change-Id: I19d8db6e3b07e1d165396c0498e328b70b2cc760
-rw-r--r--gnu/packages/check.scm25
-rw-r--r--gnu/packages/golang-check.scm25
2 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1f4c69cf99..4f593cde8d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -898,31 +898,6 @@ prevent common NGINX misconfigurations.  It provides the @command{gixy}
 command.")
       (license license:mpl2.0))))
 
-(define-public go-github.com-smartystreets-goconvey
-  (package
-    (name "go-github.com-smartystreets-goconvey")
-    (version "1.6.3")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/smartystreets/goconvey")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1ph18rkl3ns3fgin5i4j54w5a69grrmf3apcsmnpdn1wlrbs3dxh"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/smartystreets/goconvey"))
-    (propagated-inputs
-     (list go-github.com-jtolds-gls go-github.com-smartystreets-assertions))
-    (synopsis "Go testing tool with both a web and terminal user interface")
-    (description
-     "GoConvey is a testing tool for Go. It integrates with go test, can show
-test coverage and has a web user interface that will refresh automatically.")
-    (home-page "https://github.com/smartystreets/goconvey")
-    (license license:expat)))
-
 (define-public googletest
   (package
     (name "googletest")
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 0c37849806..c7b6e94791 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -412,6 +412,31 @@ Gomega matcher library.")
 functions for writing tests in Go.")
     (license license:expat)))
 
+(define-public go-github.com-smartystreets-goconvey
+  (package
+    (name "go-github.com-smartystreets-goconvey")
+    (version "1.6.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/smartystreets/goconvey")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1ph18rkl3ns3fgin5i4j54w5a69grrmf3apcsmnpdn1wlrbs3dxh"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/smartystreets/goconvey"))
+    (propagated-inputs
+     (list go-github.com-jtolds-gls go-github.com-smartystreets-assertions))
+    (home-page "https://github.com/smartystreets/goconvey")
+    (synopsis "Go testing tool with both a web and terminal user interface")
+    (description "GoConvey is a testing tool for Go. It integrates with go
+test, can show test coverage and has a web user interface that will refresh
+automatically.")
+    (license license:expat)))
+
 (define-public go-github.com-smartystreets-gunit
   (package
     (name "go-github.com-smartystreets-gunit")