summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-07 00:57:45 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2023-11-09 13:56:54 +0100
commit234be446857d5adc422d37ee49bdf2f82a0e012e (patch)
tree4c799521e7f8df23ffaf30c6a37639394a31ce6f
parent960d7ac5a56155895543e03622f6555cc162d13a (diff)
downloadguix-234be446857d5adc422d37ee49bdf2f82a0e012e.tar.gz
gnu: cl-trivial-shell: Patch shell path.
* gnu/packages/lisp-xyz.scm (sbcl-trivial-shell):
[source]: Update URL as maintainer and owner of repository was changed.
[arguments]: Add 'fix-paths phase to patch location of the shell.

Change-Id: Ib3ac95013d3cb5240eb0261ad53f484b14d8f76f
Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 4743e39d93..4e9b9894b2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17097,12 +17097,21 @@ not so easy to copy (ssyntax, argument destructuring, etc.).")
        (origin
          (method git-fetch)
          (uri (git-reference
-               (url "https://github.com/gwkkwg/trivial-shell")
+               (url "https://github.com/hraban/trivial-shell")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
           (base32 "08mpkl5ij5sjfsyn8pq2kvsvpvyvr7ha1r8g1224fa667b8k2q85"))))
       (build-system asdf-build-system/sbcl)
+      (arguments
+       (list
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'fix-paths
+              (lambda _
+                (substitute* "dev/definitions.lisp"
+                  (("/bin/sh")
+                   (which "sh"))))))))
       (native-inputs
        (list sbcl-lift))
       (home-page "https://common-lisp.net/project/trivial-shell/")