summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:49:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:25 +0200
commit235bfcd7299915123db70a059fa14089daf1db2b (patch)
treea36208ad1b7722428f490e87e9a0cb0c9d80a639
parent1fc9a69e132d3c156d6c9322860b5b21b9e30d0b (diff)
downloadguix-235bfcd7299915123db70a059fa14089daf1db2b.tar.gz
gnu: Add texlive-spalign.
* gnu/packages/tex.scm (texlive-spalign): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a4a48329a0..5168d6b7c7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6219,6 +6219,33 @@ by @code{siunitx}; @code{siunits} has maintenance-only support, now.")
 re-definitions of existing commands.")
     (license license:lppl1.3+)))
 
+(define-public texlive-spalign
+  (package
+    (name "texlive-spalign")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/spalign/" "source/latex/spalign/"
+                   "tex/latex/spalign/")
+             (base32
+              "1paxgykj07y8l5gbcz2823bn80s6y81zabqx67k0j0513ag75grf")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/spalign")
+    (synopsis
+     "Typeset matrices and arrays with spaces and semicolons as delimiters")
+    (description
+     "The purpose of this package is to decrease the number of keystrokes
+needed to typeset small amounts of aligned material (matrices, arrays, etc.).
+It provides a facility for typing alignment environments and macros with
+spaces as the alignment delimiter and semicolons (by default) as the
+end-of-row indicator.  This package also contains utility macros for
+typesetting augmented matrices, vectors, arrays, systems of equations, and
+more, and is easily extendable to other situations that use alignments.
+People who have to typeset a large number of matrices (like linear algebra
+teachers) should find this package to be a real time saver.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")