summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 20:49:23 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit243a009adacd85b6e742b754433d99624742c840 (patch)
tree5ec14ebb551f29bb13941495c94a14eada2903aa
parentb24a0c00e40a976c908ffc2245aeb14ee87f96c0 (diff)
downloadguix-243a009adacd85b6e742b754433d99624742c840.tar.gz
gnu: Add python-coverage.
* gnu/packages/python.scm (python-coverage, python2-coverage): New variables.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 57d8daf432..4577940946 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1326,6 +1326,34 @@ have failed since the last commit or what tests are currently failing.")
 (define-public python2-testrepository
   (package-with-python2 python-testrepository))
 
+(define-public python-coverage
+  (package
+    (name "python-coverage")
+    (version "3.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/c/coverage/coverage-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "0knlbq79g2ww6xzsyknj9rirrgrgc983dpa2d9nkdf31mb2a3bni"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "http://nedbatchelder.com/code/coverage")
+    (synopsis "Code coverage measurement for Python")
+    (description
+     "Coverage measures code coverage, typically during test execution.  It
+uses the code analysis tools and tracing hooks provided in the Python standard
+library to determine which lines are executable, and which have been
+executed.")
+    (license bsd-3)))
+
+(define-public python2-coverage
+  (package-with-python2 python-coverage))
+
 (define-public behave
   (package
     (name "behave")