summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 15:51:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:30 +0200
commit244879c9032ecd15a43f8a230bede824253e066f (patch)
tree96e4c69f479db46f46826da2be56fcca701cfd0d
parent1e81d36897da42ef8dbf34f50bc9cf66218d7681 (diff)
downloadguix-244879c9032ecd15a43f8a230bede824253e066f.tar.gz
gnu: Add texlive-drawstack.
* gnu/packages/tex.scm (texlive-drawstack): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 02087be300..baad754a4e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3221,6 +3221,26 @@ options allow to change the visualizations, e.g., drawing rectangular,
 triangular, or banded matrices.")
     (license license:expat)))
 
+(define-public texlive-drawstack
+  (package
+    (name "texlive-drawstack")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/drawstack/"
+                   "tex/latex/drawstack/")
+             (base32
+              "1qv2j7crg4b1ggxvmjb6zf0cxmr4mmpk382l7w3dqhywf9lr722v")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/drawstack")
+    (synopsis "Draw execution stacks")
+    (description
+     "This simple LaTeX package provides support for drawing execution stack
+(typically to illustrate assembly language notions).  The code is written on
+top of TikZ.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")