summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-09-23 21:29:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-09-25 21:44:30 +0200
commit246bc76a157b324b69412e5dd1e4ce22d45944da (patch)
treed9d3b73407d1788b1a629ec36f5f1b52f6d0adf4
parent22af90291f4028d154f99dbddf268a47a3f2ea08 (diff)
downloadguix-246bc76a157b324b69412e5dd1e4ce22d45944da.tar.gz
gnu: Add python-nbxmpp.
* gnu/packages/messaging.scm (python-nbxmpp, python2-nbxmpp): New
  variables.
-rw-r--r--gnu/packages/messaging.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 7263a3810f..6471501a6b 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,13 +22,14 @@
 
 (define-module (gnu packages messaging)
   #:use-module ((guix licenses)
-                #:select (gpl2+ gpl2 lgpl2.1 lgpl2.0+ bsd-2 non-copyleft
+                #:select (gpl3+ gpl2+ gpl2 lgpl2.1 lgpl2.0+ bsd-2 non-copyleft
                           asl2.0))
   #:use-module (guix utils)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
+  #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages avahi)
@@ -393,4 +395,30 @@ clients from different locations can connect to a single ZNC account
 simultaneously and therefore appear under the same nickname on IRC.")
     (license asl2.0)))
 
+(define-public python-nbxmpp
+  (package
+    (name "python-nbxmpp")
+    (version "0.5.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://pypi.python.org/packages/source/n/nbxmpp/"
+                           "nbxmpp-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0dcr786dyips1fdvgsn8yvpgcz5j7217fi05c29cfypdl8jnp6mp"))))
+    (build-system python-build-system)
+    ;; No tests included
+    (arguments `(#:tests? #f))
+    (home-page "http://python-nbxmpp.gajim.org")
+    (synopsis "Non-blocking Jabber/XMPP module")
+    (description
+     "The goal of this python library is to provide a way for Python
+applications to use Jabber/XMPP networks in a non-blocking way.  This library
+was initially a fork of xmpppy, but is using non-blocking sockets.")
+    (license gpl3+)))
+
+(define-public python2-nbxmpp
+  (package-with-python2 python-nbxmpp))
+
 ;;; messaging.scm ends here