summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 23:41:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:52 +0200
commit260140f3313b485469822e7d57a24400c736d151 (patch)
tree8085996bdbb20699b7577a5e03a979e0e5d249d8
parentdf2b6cd2b1053a3df6bdc4e683581a85a32f275f (diff)
downloadguix-260140f3313b485469822e7d57a24400c736d151.tar.gz
gnu: texlive-numprint: Refresh package definition.
* gnu/packages/tex.scm (texlive-numprint): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm64
1 files changed, 27 insertions, 37 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c42bcfc5ec..f0a86cb544 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9221,43 +9221,33 @@ toc-entries;
     (license license:lppl)))
 
 (define-public texlive-numprint
-  (let ((template
-         (simple-texlive-package
-          "texlive-numprint"
-          (list "doc/latex/numprint/"
-                "source/latex/numprint/"
-                "tex/latex/numprint/")
-          (base32 "1rqbqj4ffcfxxxxbs100pdslaiimwzgg19mf2qzcmm5snxwrf7zj"))))
-    (package
-      (inherit template)
-      (outputs '("out" "doc"))
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ '())
-          "latex/numprint")
-         ((#:build-targets _ '())
-          '(list "numprint.ins"))))
-      (home-page "https://www.ctan.org/pkg/numprint")
-      (synopsis "Print numbers with separators and exponent if necessary")
-      (description
-       "The package numprint prints numbers with a separator every three
-digits and converts numbers given as 12345.6e789 to 12\\,345,6\\cdot
-10^{789}.  Numbers are printed in the current mode (text or math) in
-order to use the correct font.
-
-Many things, including the decimal sign, the thousand separator, as
-well as the product sign can be changed by the user, e.g., to reach
-12,345.6\\times 10^{789}.
-
-If an optional argument is given it is printed upright as unit.
-Numbers can be rounded to a given number of digits.  The package
-supports an automatic, language-dependent change of the number format.
-
-Tabular alignment using the tabular, array, tabularx, and longtable
-environments (similar to the dcolumn and rccol packages) is supported
-using all features of numprint.  Additional text can be added before
-and after the formatted number.")
-      (license license:lppl))))
+  (package
+    (name "texlive-numprint")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/numprint/" "source/latex/numprint/"
+                   "tex/latex/numprint/")
+             (base32
+              "1rqbqj4ffcfxxxxbs100pdslaiimwzgg19mf2qzcmm5snxwrf7zj")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-tools))
+    (home-page "https://ctan.org/pkg/numprint")
+    (synopsis "Print numbers with separators and exponent if necessary")
+    (description
+     "The package numprint prints numbers with a separator every three digits
+and converts numbers given as @samp{12345.6e789} to @samp{12\\,345,6\\cdot
+10^@{789@}}.  Numbers are printed in the current mode (text or math) in order
+to use the correct font.
+
+Many things, including the decimal sign, the thousand separator, as well as
+the product sign can be changed by the user.  If an optional argument is given
+it is printed upright as unit.  Numbers can be rounded to a given number of
+digits.  The package supports an automatic, language-dependent change of the
+number format.")
+    (license license:lppl)))
 
 (define-deprecated-package texlive-latex-numprint texlive-numprint)