summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-05-12 12:43:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-12 15:30:44 +0200
commit263f235cd0a2955e865fe38036f84c2bf34375ff (patch)
tree4c503c04742b9244fb8c49bfb339dee7ddfb301e
parent40310efde9b4a4f2cf98081d6cd10f843685ebb6 (diff)
downloadguix-263f235cd0a2955e865fe38036f84c2bf34375ff.tar.gz
gnu: Add python-mgatk.
* gnu/packages/bioinformatics.scm (python-mgatk): New variable.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioinformatics.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index afca5ab93b..500c418b13 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12628,6 +12628,56 @@ single-cell RNA-seq data.")
 API services.")
     (license license:bsd-3)))
 
+(define-public python-mgatk
+  (package
+    (name "python-mgatk")
+    (version "0.6.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/caleblareau/mgatk")
+             ;; There is no tag for 0.6.7, but this is the commit
+             ;; corresponding to the version bump.
+             (commit "2633903acb1fb406bb58c787f320c3641f446ee7")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "19iklfv1brwsfg1l5lrs3z8m343nskkn1998c1fs7fdn0lgrki2p"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; The md5 module has been removed in Python 3
+          (add-after 'unpack 'python3-compatibility
+            (lambda _
+              (substitute* "tests/test_cli.py"
+                (("import md5") "from hashlib import md5")
+                (("md5.new") "md5")
+                (("\\.digest") ".hexdigest")))))))
+    (propagated-inputs
+     (list python-biopython
+           python-click
+           python-numpy
+           python-optparse-pretty
+           python-pandas
+           python-pysam
+           python-regex
+           python-ruamel.yaml
+           snakemake))
+    (native-inputs
+     (list python-pytest))
+    (home-page "https://github.com/caleblareau/mgatk")
+    (synopsis "Mitochondrial genome analysis toolkit.")
+    (description "This package is a Python-based command line interface for
+processing .bam files with mitochondrial reads and generating high-quality
+heteroplasmy estimation from sequencing data.  The mgatk package places a
+special emphasis on mitochondrial genotypes generated from single-cell
+genomics data, primarily @acronym{mtscATAC-seq, mitochondrial single-cell
+ATAC-sequence}, but is generally applicable across other assays.")
+    (license license:expat)))
+
 (define-public python-multivelo
   (package
     (name "python-multivelo")