summary refs log tree commit diff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-06-06 22:13:03 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-06-07 09:13:52 +0300
commit2660f99b5761d215555dc0f95a562ba68e4a0f77 (patch)
tree69bbf63218e574dbe7a2517779cb72186ad8db0d
parent2680f30a2e75c9853357792a891983a2cfa2d80b (diff)
downloadguix-2660f99b5761d215555dc0f95a562ba68e4a0f77.tar.gz
gnu: python-pycodestyle: Update to 2.8.0.
* gnu/packages/python-xyz.scm (python-pycodestyle): Update to 2.8.0.
[arguments]: Respect tests?.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7c9c0b2cc6..56a3972703 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6468,21 +6468,22 @@ a simple netcat replacement with chaining support.")
 (define-public python-pycodestyle
   (package
     (name "python-pycodestyle")
-    (version "2.7.0")
+    (version "2.8.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pycodestyle" version))
        (sha256
         (base32
-         "1vqwmzmjdv331kmfq3q9j3as2x7r2r49lf83r9w4147pdg8c32f3"))))
+         "0zxyrg8029lzjhima6l5nk6y0z6lm5wfp9qchz3s33j3xx3mipgd"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (invoke "pytest" "-vv"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "-vv")))))))
     (native-inputs
      (list python-pytest))
     (home-page "https://pycodestyle.readthedocs.io/")