summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-03 04:18:25 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-05-08 13:00:39 +0200
commit266ad5d740dfccf8acc0cea62d33238ea34e4d3d (patch)
tree265f92efdb458a2c6fce9abe18ed2ebf714c8220
parent6028f3a1d86c9f3160493aade70713df2524e7c1 (diff)
downloadguix-266ad5d740dfccf8acc0cea62d33238ea34e4d3d.tar.gz
gnu: Add zrtpcpp.
* gnu/packages/telephony.scm (zrtpcpp): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/telephony.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 17974e17f9..6956d5efed 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -48,6 +48,7 @@
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crypto)
+  #:use-module (gnu packages databases)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages file)
@@ -257,6 +258,37 @@ packet-manipulation library.")
    (license license:gpl2+) ; plus runtime exception
    (home-page "https://www.gnu.org/software/ccrtp/")))
 
+(define-public zrtpcpp
+  (package
+    (name "zrtpcpp")
+    (version "4.6.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/wernerd/ZRTPCPP.git")
+         (commit
+          (string-append "V" version))))
+       (file-name
+        (git-file-name name version))
+       (sha256
+        (base32
+         "06vphvh4dgi7ah5qkq53wqvswv8l273x0xwbc447qmgvamm0x1vs"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))                    ; No target
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("ccrtp" ,ccrtp)
+       ("ucommon" ,ucommon)))
+    (synopsis "C++ Implementation of ZRTP protocol")
+    (description  "GNU ZRTP C++ provides a library that adds ZRTP support to the
+GNU ccRTP stack and serves as library for other RTP stacks
+(PJSIP, GStreamer).")
+    (home-page "https://www.gnu.org/software/ccrtp/zrtp")
+    (license license:lgpl3+)))
 
 (define-public osip
   (package