summary refs log tree commit diff
diff options
context:
space:
mode:
authorDistopico <distopico@riseup.net>2023-08-30 14:58:15 -0500
committerLudovic Courtès <ludo@gnu.org>2023-09-09 15:54:38 +0200
commit26c10ac9bf373475f08442d52e2162ec2504f265 (patch)
treed132bb0fae6eb8febbe0f80a1f765ef1be69cc0c
parenta4514556df4e3138544def7286c6ecf640634a57 (diff)
downloadguix-26c10ac9bf373475f08442d52e2162ec2504f265.tar.gz
gnu: Add rust-either-1.6.0.
* gnu/packages/crates-io.scm (rust-either-1.6.0): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/crates-io.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b6e2ac4507..6a0f4e187d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21557,6 +21557,24 @@ signing, and verification in pure Rust.")
 @code{Right} is a general purpose sum type with two cases.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-either-1.6.0
+  (package
+    (inherit rust-either-1)
+    (name "rust-either")
+    (version "1.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "either" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0mwl9vngqf5jvrhmhn9x60kr5hivxyjxbmby2pybncxfqhf4z3g7"))))
+    (arguments
+     `(#:cargo-inputs (("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs (("rust-serde-json" ,rust-serde-json-1.0.73))))))
+
 (define-public rust-elf-0.0.10
   (package
     (name "rust-elf")