summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-15 20:30:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-26 23:36:40 -0400
commit279908ef510342b967f9ce25e5ff969f9c0ca55d (patch)
tree67770b6ffc4a006c1987dd8d33138b3a514bafa0
parent05e0bd07d4fcfd082a8095150a86ceacb4635b7c (diff)
downloadguix-279908ef510342b967f9ce25e5ff969f9c0ca55d.tar.gz
gnu: bcmatroska2: Fetch the sources from git.
* gnu/packages/linphone.scm (bcmatroska2)[source]: Fetch sources from git.
[description]: Expound description.
[license]: Add the gpl2+ license to the list.  Remove broken URLs.
-rw-r--r--gnu/packages/linphone.scm31
1 files changed, 13 insertions, 18 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 19b50170d2..078185046f 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -209,31 +209,26 @@ format.")
     (version "0.23")
     (source
      (origin
-       (method url-fetch)
-       (uri
-        (string-append "https://www.linphone.org/releases/sources/" name
-                       "/" name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.linphone.org/BC/public/bcmatroska2.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1a0vlk4fhh189pfzrwbc3xbc5vyx6cnxy642d1h40045jz9y4h15"))))
+        (base32 "1avl9w18kh4dxm3g8j0bkw39bksd7bz3nfxvyibqqnz63ds8vfi2"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f                      ; No test target
-       #:configure-flags
-       (list
-        "-DENABLE_STATIC=NO")))         ; Not required
+     `(#:tests? #f                                     ; No test target
+       #:configure-flags (list "-DENABLE_STATIC=NO"))) ; Not required
     (synopsis "Belledonne Communications Media Container")
     (description "BcMatroska is a free and open standard multi-media container
 format.  It can hold an unlimited number of video, audio, picture, or subtitle
-tracks in one file. ")
+tracks in one file.  This project provides a convenient distribution of the
+Matroska multimedia container format.")
     (home-page "https://gitlab.linphone.org/BC/public/bcmatroska2")
-    (license
-     (list
-      ;; For Core C and LibEBML2.
-      ;; https://www.matroska.org/node/47
-      license:bsd-4
-      ;; For LibMatroska2.
-      ;; https://www.matroska.org/node/47
-      license:lgpl2.1+))))
+    (license (list license:gpl2+        ;for this package (build system files)
+                   license:bsd-4        ;for Core C and LibEBML2
+                   license:lgpl2.1+)))) ;for LibMatroska2
 
 (define-public bcg729
   (package