summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-12-07 12:32:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-12-07 12:48:07 +0200
commit27cf23874402f7132df8bb84a5501ae88abb240a (patch)
tree394d7eb4aa137ca3f0ba2f46e5b78ac90334e015
parent3832704aff7444e26ba7f6915bdb4f718b1bf2f4 (diff)
downloadguix-27cf23874402f7132df8bb84a5501ae88abb240a.tar.gz
Revert "gnu: vim: Run more tests."
This reverts commit 17a53aec7a6a7608bd01841ca2058bfe1500c453.

This breaks building vim on ARM architectures.
-rw-r--r--gnu/packages/vim.scm36
1 files changed, 15 insertions, 21 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index baf6ca91cf..81d5ab00c9 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -121,36 +121,30 @@
              (substitute* "src/testdir/test_swap.vim"
                (("if !IsRoot\\(\\)") "if 0"))
 
-             ;; These tests compares output against a golden ‘…/|b|i|n|/|s|h…’
+             ;; These tests check how the terminal looks after executing some
+             ;; actions.  The path of the bash binary is shown, which results in
+             ;; a difference being detected.  Patching the expected result is
+             ;; non-trivial due to the special format used, so skip the test.
+             (substitute* "src/testdir/test_terminal.vim"
+               ((".*Test_terminal_postponed_scrollback.*" line)
+                (string-append line "return\n")))
+             (substitute* "src/testdir/test_popupwin.vim"
+               ((".*Test_popup_drag_termwin.*" line)
+                (string-append line "return\n")))
+
+             ;; This test compares output against a golden ‘…/|b|i|n|/|s|h…’
              ;; literal.  We need to match that and substitute a similarly
              ;; ‘spliced’ path to ‘sh’ in the store, truncated to the last
-             ;; 44 (spliced: 88) or so characters.
-             ;; Two of the tests we simply skip instead of patching the screen dump.
-             (substitute* "src/testdir/test_popupwin.vim"
-               ((".*Test_popupwin_term_0[1|2].*") ""))
-             ;; We replace the external program call (!) with a scroll-back (<)
-             ;; symbol and blindly fix some other differences based on error output.
+             ;; 44 (spliced: 88) characters.
              (let ((splice (lambda (s separator)
                                (string-join (map string (string->list s))
                                             separator))))
                (substitute* "src/testdir/dumps/Test_terminal_from_cmd.dump"
                  (((splice "/bin/sh" "\\|"))
                   (splice (string-take-right (which "sh") 44) "|"))
+                 ;; Blindly fix some other differences based on error output.
                  (("^\\|!") "|<")
-                 (("@37") ""))
-               (substitute* '("src/testdir/dumps/Test_terminal_scrollback_1.dump"
-                              "src/testdir/dumps/Test_terminal_scrollback_2.dump")
-                 (((splice "/bin/sh" "\\|"))
-                  (splice (string-take-right (which "sh") 61) "|"))
-                 (("^\\|!") "|<")
-                 ((" @55") " @1"))
-               (substitute* '("src/testdir/dumps/Test_terminal_scrollback_3.dump"
-                              "src/testdir/dumps/Test_popupwin_term_03.dump"
-                              "src/testdir/dumps/Test_popupwin_term_04.dump")
-                 (((splice "/bin/sh" "\\|"))
-                  (splice (string-take-right (which "sh") 62) "|"))
-                 (("^\\|!") "|<")
-                 (("\\]\\| @56") "]| @1")))
+                 (("@37") "")))
              #t)))))
     (inputs
      `(("gawk" ,gawk)