summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 17:10:34 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 17:11:33 +0100
commit2860bb2779dbc557ab5362b531d9f497f34b41d8 (patch)
tree335a6cdadd83d44df9837b031d260b3f7ec3860f
parent55bf2d31e92b27b2a72116e10f4b0b832f7c9139 (diff)
downloadguix-2860bb2779dbc557ab5362b531d9f497f34b41d8.tar.gz
gnu: mdadm-static: Fix build.
This follows up on commit 3d7a1b84c5bc3219c6076e492d6e98c27f2c1f86.

* gnu/packages/linux.scm (mdadm-static)[arguments]:
Add "-DNO_LIBUDEV" to CXFLAGS.
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5e75caf821..baed31a510 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5078,7 +5078,9 @@ arrays when needed.")
     (arguments
      (substitute-keyword-arguments (package-arguments mdadm)
        ((#:make-flags flags)
-        #~(cons "LDFLAGS = -static" #$flags))
+        #~(cons* "LDFLAGS = -static"
+                 "CXFLAGS = -DNO_LIBUDEV"
+                 #$flags))
        ((#:phases phases)
         #~(modify-phases #$phases
             (add-after 'install 'remove-cruft