summary refs log tree commit diff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-11-03 09:27:56 +0800
committerChristopher Baines <mail@cbaines.net>2023-11-05 18:14:26 +0000
commit286639c9af49dc56dce68a5483fd8ca3aeaecdb0 (patch)
treecc569872a3d345677196d1f6fc275844db0089cb
parentc5267d334af396d2a515b84f69660b60eadbd29a (diff)
downloadguix-286639c9af49dc56dce68a5483fd8ca3aeaecdb0.tar.gz
gnu: phantomsocks: Update to 0.0.0-20231031033204-8b0ac27fc450.
* gnu/packages/networking.scm (phantomsocks): Update to
0.0.0-20231031033204-8b0ac27fc450.
[arguments]<#:go>: Use go-1.20.

Change-Id: I8cee734d5582c99b7940591ba14fba927992a201
Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/networking.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 86309e4ab3..b0381515a5 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4540,7 +4540,7 @@ on hub/switched networks.  It is based on @acronym{ARP} packets, it will send
 (define-public phantomsocks
   (package
     (name "phantomsocks")
-    (version "0.0.0-20230829023258-013a0002abe2")
+    (version "0.0.0-20231031033204-8b0ac27fc450")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -4549,10 +4549,11 @@ on hub/switched networks.  It is based on @acronym{ARP} packets, it will send
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0pqq4mh6dr7fb7i001wggwkxpvavxq0ps9h2cmm4gv8ygh4v6f10"))))
+                "1q4i8pgj6hzry9wzlczx729dmmgqdqfb26rfaim2ngmp1dyy9drl"))))
     (build-system go-build-system)
     (arguments
-     (list #:install-source? #f
+     (list #:go go-1.20
+           #:install-source? #f
            #:import-path "github.com/macronut/phantomsocks"
            #:build-flags #~'("-tags" #$(if (target-linux?)
                                            "rawsocket"