summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-02-02 12:12:52 -0500
committerMark H Weaver <mhw@netris.org>2015-02-02 12:13:58 -0500
commit288084d5355232be11c98945c507d0639bf5bc40 (patch)
tree36d0e49439321a66e1605235010a8cfe08d802b1
parent01d8ac64abaac9202c32848f7c4a394393ba6534 (diff)
downloadguix-288084d5355232be11c98945c507d0639bf5bc40.tar.gz
gnu: Add hdparm.
* gnu/packages/linux.scm (hdparm): New variable.
-rw-r--r--gnu/packages/linux.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8383bfa338..f48235672e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1785,3 +1785,30 @@ an isolated container, created with the help of Linux namespaces.  It is
 similar in functionality to chroot, although pflask provides better isolation
 thanks to the use of namespaces.")
     (license bsd-2)))
+
+(define-public hdparm
+  (package
+    (name "hdparm")
+    (version "9.45")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/" name "/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0sc6yf3k6sd7n6a2ig2my9fjlqpak3znlyw7jw4cz5d9asm1rc13"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (let ((out (assoc-ref %outputs "out")))
+                      (list (string-append "binprefix=" out)
+                            (string-append "manprefix=" out)
+                            "CC=gcc"))
+       #:phases (alist-delete 'configure %standard-phases)
+       #:tests? #f))  ; no test suite
+    (home-page "http://sourceforge.net/projects/hdparm/")
+    (synopsis "tune hard disk parameters for high performance")
+    (description
+     "Get/set device parameters for Linux SATA/IDE drives.  It's primary use
+is for enabling irq-unmasking and IDE multiplemode.")
+    (license (bsd-style "file://LICENSE.TXT"))))
+