summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-12 23:27:25 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-12 23:27:25 +0200
commit288a09ca91f1847392d9e7ab47fa059b070a5ee8 (patch)
treeee74835a2cf4175da22f959e3471853256f233cf
parenta49c57a7931589001695397ccf03c4c91b4e1045 (diff)
downloadguix-288a09ca91f1847392d9e7ab47fa059b070a5ee8.tar.gz
gnu: make-bootstrap: Fix compilation of %gcc-static.
* gnu/packages/make-bootstrap.scm (%gcc-static)[arguments]
  <#:configure-flags>: Add --disable-bootstrap
  --with-stage1-ldflags=-static.
  Remove #:make-flags.
-rw-r--r--gnu/packages/make-bootstrap.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index a6079553cc..a09363a855 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -405,6 +405,12 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
             ((#:implicit-inputs? _) #t)
             ((#:configure-flags flags)
              `(append (list
+                       ;; We don't need a full bootstrap here.
+                       "--disable-bootstrap"
+
+                       ;; Make sure '-static' is passed where it matters.
+                       "--with-stage1-ldflags=-static"
+
                        "--disable-shared"
                        "--disable-plugin"
                        "--enable-languages=c"
@@ -417,11 +423,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                        "--disable-libquadmath"
                        "--disable-decimal-float")
                       (remove (cut string-match "--(.*plugin|enable-languages)" <>)
-                              ,flags)))
-            ((#:make-flags flags)
-             (if (%current-target-system)
-                 `(cons "LDFLAGS=-static" ,flags)
-                 `(cons "BOOT_LDFLAGS=-static" ,flags))))))
+                              ,flags))))))
      (native-inputs
       (if (%current-target-system)
           `(;; When doing a Canadian cross, we need GMP/MPFR/MPC both