summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:08 +0200
commit289b521584abc587140cfa047984e73eac119903 (patch)
treebb8a2bdcef408139ca7cd3514b79aa67ed1cf17a
parent64b12a1abfd7562c6d0652d05aad8cedf5400d9c (diff)
downloadguix-289b521584abc587140cfa047984e73eac119903.tar.gz
gnu: python-pyodbc-c: Don't use unstable tarball.
* gnu/packages/databases.scm (python-pyodbc-c)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/databases.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index fd8cc5187c..ce7723b45f 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3021,13 +3021,13 @@ development.")
     (version "3.1.4")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://gitlab.com/daym/pyodbc-c/repository/"
-                           "archive.tar.gz?ref=v" version))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/daym/pyodbc-c/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "05aq2297k779xidmxcwkrrxjvj1bh2q7d9a1rcjv6zr15y764ga9"))
-       (file-name (string-append name "-" version ".tar.gz"))))
+        (base32 "1mm2vif3b5yq0j6x3idl748w37n2i6j0clah3h967jyrl4p2c7vi"))))
     (build-system python-build-system)
     (inputs
      (list unixodbc))