summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-11-24 15:58:57 -0500
committerKei Kebreau <kkebreau@posteo.net>2017-11-25 16:13:37 -0500
commit2af6be91d59ad5aefe01e90aa9045e26d8667098 (patch)
treef2ced90d56de2cb8a085dc00c4da67279b0cb818
parent5ea35b42e451039e170224c429be37012878cff1 (diff)
downloadguix-2af6be91d59ad5aefe01e90aa9045e26d8667098.tar.gz
gnu: diffoscope: Fix error messages related to comparison tools.
* gnu/packages/package-management.scm (diffoscope)[arguments]: Replace readelf
substitution and add stat and getfacl substitutions.
[inputs]: Add acl.

Errors fixed include the following:
  "FileNotFoundError: [Errno 2] No such file or directory: 'readelf'"
  "diffoscope.comparators.directory: Unable to find 'getfacl', some directory
   metadata differences might not be noticed."
  "diffoscope.comparators.directory: Unable to find 'stat'"
-rw-r--r--gnu/packages/package-management.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c7a3681161..15c310d6e6 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -63,6 +63,7 @@
   #:use-module (gnu packages ssh)
   #:use-module (gnu packages vim)
   #:use-module (gnu packages serialization)
+  #:use-module (gnu packages acl)
   #:use-module (srfi srfi-1)
   #:use-module (ice-9 match))
 
@@ -520,7 +521,6 @@ transactions from C or Python.")
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
-                  (add-before 'unpack 'n (lambda _ #t))
                   ;; setup.py mistakenly requires python-magic from PyPi, even
                   ;; though the Python bindings of `file` are sufficient.
                   ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815844
@@ -535,8 +535,15 @@ transactions from C or Python.")
                          (string-append "['" (which "xxd") "',")))
                       (substitute* "diffoscope/comparators/elf.py"
                         (("@tool_required\\('readelf'\\)") "")
-                        (("\\['readelf',")
-                         (string-append "['" (which "readelf") "',")))
+                        (("get_tool_name\\('readelf'\\)")
+                         (string-append "'" (which "readelf") "'")))
+                      (substitute* "diffoscope/comparators/directory.py"
+                        (("@tool_required\\('stat'\\)") "")
+                        (("@tool_required\\('getfacl'\\)") "")
+                        (("\\['stat',")
+                         (string-append "['" (which "stat") "',"))
+                        (("\\['getfacl',")
+                         (string-append "['" (which "getfacl") "',")))
                       #t))
                   (add-before 'check 'delete-failing-test
                     (lambda _
@@ -547,6 +554,7 @@ transactions from C or Python.")
               ("python-debian" ,python-debian)
               ("python-libarchive-c" ,python-libarchive-c)
               ("python-tlsh" ,python-tlsh)
+              ("acl" ,acl)                        ;for getfacl
               ("colordiff" ,colordiff)
               ("xxd" ,xxd)