summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-19 16:01:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-19 16:01:59 +0200
commit2c9787086a9b0e1ab3b63e304f778c5d46dce0e6 (patch)
treeb6e3c766046c631a10b59b3a784f9e1ce4db01ba
parentb8aa43138250a3fc1d614418011ae47ac1685a92 (diff)
downloadguix-2c9787086a9b0e1ab3b63e304f778c5d46dce0e6.tar.gz
gnu: python-xdo: Use libc already in build environment.
* gnu/packages/python-xyz.scm (python-xdo)[arguments]: Find reference to
'libc' input.
[inputs]: Remove glibc.
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 757afbbba5..80c36e3f55 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14315,7 +14315,7 @@ in pure Python.")
                             (assoc-ref inputs "xdotool")
                             "/lib/libxdo.so"))
                    (libc (string-append
-                          (assoc-ref inputs "glibc")
+                          (assoc-ref inputs "libc")
                           "/lib/libc.so.6")))
                (substitute* "xdo/_xdo.py"
                  (("find_library\\(\"xdo\"\\)")
@@ -14328,7 +14328,6 @@ in pure Python.")
      (list python-six))
     (inputs
      `(("xdotool" ,xdotool)
-       ("glibc" ,glibc)
        ("libX11" ,libx11)))
     (home-page "https://tracker.debian.org/pkg/python-xdo")
     (synopsis "Python library for simulating X11 keyboard/mouse input")