summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:00 +0200
commit2d80b869f0158b8b6d830cc9dbbaa78d3681ced1 (patch)
treed70eecdc4571aeceddc93e1d6b9a35e290fd748f
parent495c248920eeff84146e0fb6ed73cd47661a28ec (diff)
downloadguix-2d80b869f0158b8b6d830cc9dbbaa78d3681ced1.tar.gz
gnu: c-blosc: Remove bundled libraries from source.
* gnu/packages/compression.scm (c-blosc)[source]: Add snippet.
-rw-r--r--gnu/packages/compression.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 9d8106b6d5..d4a52ff111 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -2576,15 +2576,19 @@ chunks.")
   (package
     (name "c-blosc")
     (version "1.21.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/Blosc/c-blosc")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0gy9a7wp7x71x5l3rprx8wpb3c5cn7wqc77gdiffq35hr34q88p9"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Blosc/c-blosc")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0gy9a7wp7x71x5l3rprx8wpb3c5cn7wqc77gdiffq35hr34q88p9"))
+       (modules '((guix build utils)))
+       (snippet
+        ;; In a rare victory, we may delete all bundled libs to no ill effect.
+        '(delete-file-recursively "internal-complibs"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags