summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-10 23:55:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:47 +0200
commit2dea2e8956965f82cfc73bb9be188fd891f37cc7 (patch)
tree4ec273a171e1a52852572a17447e28d37c647c99
parentb217a4c4b0898719a1aa1a0fda6373a2e7477f03 (diff)
downloadguix-2dea2e8956965f82cfc73bb9be188fd891f37cc7.tar.gz
gnu: Add texlive-germbib.
* gnu/packages/tex.scm (texlive-germbib): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f4d59bb1d4..5ba17adcbc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -31496,6 +31496,28 @@ generation based on the @code{fifinddo} package.")
 Rechtschreibung).")
     (license license:lppl)))
 
+(define-public texlive-germbib
+  (package
+    (name "texlive-germbib")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/germbib/" "doc/bibtex/germbib/"
+                   "tex/latex/germbib/")
+             (base32
+              "1mc95h4ndzbg2q30vsq2rx9v0a8f0q0vhmjiz709lllkmj6n402p")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/germbib")
+    (synopsis "German variants of standard BibTeX styles")
+    (description
+     "This package provides a development of the (old) @file{german.sty}, this
+bundle provides German packages, BibTeX styles and documentary examples, for
+writing documents with bibliographies.  The author has since developed the
+@code{babelbib} bundle, which (he asserts) supersedes @code{germbib}.")
+    ;; The license is a variation of Knuth's.
+    (license (license:fsf-free "file://doc/bibtex/germbib/apalike.tex"))))
+
 (define-public texlive-logreq
   (package
     (name "texlive-logreq")