summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-07-03 21:31:10 +0000
committerAndreas Enge <andreas@enge.fr>2023-07-26 16:11:31 +0200
commit2e3edb38a578e16ae966a956cbf390bd97d96989 (patch)
treef8f0a3562af8c3cae54b78806d1893e31d1f183a
parent9ca9b0afb641f045e0021a00ced579ca1615af5b (diff)
downloadguix-2e3edb38a578e16ae966a956cbf390bd97d96989.tar.gz
gnu: python-pymol: Fix launch script.
* gnu/packages/chemistry.scm (python-pymol)[#:phases]: Add 'disable-unchroot.
[native-inputs]: Remove python-setuptools.

Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/chemistry.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index bee540bc16..05aaa827f8 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2022 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2022, 2023 David Elsing <david.elsing@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -554,6 +554,12 @@ symmetries written in C.  Spglib can be used to:
                                     (assoc-ref inputs "libxml2")
                                     "/include/libxml2:"
                                     (getenv "CPLUS_INCLUDE_PATH")))))
+         ;; Prevent deleting the leading / in the __init__.py path in the
+         ;; launch script.
+         (add-after 'unpack 'disable-unchroot
+           (lambda _
+             (substitute* "setup.py"
+               (("self\\.unchroot") ""))))
          ;; The setup.py script does not support one of the Python build
          ;; system's default flags, "--single-version-externally-managed".
          (replace 'install
@@ -572,8 +578,7 @@ symmetries written in C.  Spglib can be used to:
            python-pyqt
            glm
            netcdf))
-    (native-inputs
-     (list catch2 python-setuptools))
+    (native-inputs (list catch2))
     (home-page "https://pymol.org")
     (synopsis "Molecular visualization system")
     (description "PyMOL is a capable molecular viewer and renderer.  It can be