summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 19:49:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:03 +0200
commit2e9542d58792100a564f06354e8b1e6adc20f07c (patch)
tree500d9052ab0e1814ae1b1c1a9b2944c64486b3b8
parent69fef3f7b599943273af3bd65fe14336e5c70c51 (diff)
downloadguix-2e9542d58792100a564f06354e8b1e6adc20f07c.tar.gz
gnu: rust-md5: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-md5-0.7, rust-md5-0.6, rust-md5-0.3,
rust-md5-asm-0.5, rust-md5-asm-0.4): Move from here ...
* gnu/packages/crates-crypto.scm: ... to here.

Change-Id: Ide9a22a64358fc6ada172fa37e0df28c34b0b1e6
-rw-r--r--gnu/packages/crates-crypto.scm88
-rw-r--r--gnu/packages/crates-io.scm88
-rw-r--r--gnu/packages/syndication.scm1
3 files changed, 89 insertions, 88 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index a08f8bea74..9aed8fe97a 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -2634,6 +2634,94 @@ Hash-based Message Authentication Code algorithm} for SHA1.")
        (("rust-digest" ,rust-digest-0.8)
         ("rust-hex-literal" ,rust-hex-literal-0.1))))))
 
+(define-public rust-md5-0.7
+  (package
+    (name "rust-md5")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "md5" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0wcps37hrhz59fkhf8di1ppdnqld6l1w5sdy7jp7p51z0i4c8329"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t))
+    (home-page "https://github.com/stainless-steel/md5")
+    (synopsis "MD5 hash function in Rust")
+    (description "The package provides the MD5 hash function.")
+    (license (list license:asl2.0
+                   license:expat))))
+
+(define-public rust-md5-0.6
+  (package
+    (inherit rust-md5-0.7)
+    (name "rust-md5")
+    (version "0.6.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "md5" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "17b2xm4h4cvxsdjsf3kdrzqv2za60kak961xzi5kmw6g6djcssvy"))))))
+
+(define-public rust-md5-0.3
+  (package
+    (inherit rust-md5-0.6)
+    (name "rust-md5")
+    (version "0.3.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "md5" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0j2s8aqdkhwhy7awga2bmv5n8qq8bgy8672iha9f3y871dm6vibr"))))))
+
+(define-public rust-md5-asm-0.5
+  (package
+    (name "rust-md5-asm")
+    (version "0.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "md5-asm" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1ixmkg8j7sqy9zln6pz9xi2dl2d9zpm8pz6p49za47n1bvradfbk"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-cc" ,rust-cc-1))))
+    (home-page "https://github.com/RustCrypto/asm-hashes")
+    (synopsis "Assembly implementation of MD5 compression function")
+    (description
+     "This package contains an assembly implementation of the MD5
+compression function.")
+    (supported-systems '("x86_64-linux" "i686-linux"))
+    (license license:expat)))
+
+(define-public rust-md5-asm-0.4
+  (package
+    (inherit rust-md5-asm-0.5)
+    (name "rust-md5-asm")
+    (version "0.4.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "md5-asm" version))
+        (file-name
+         (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "0gpk5647js1k084jc7pg2gji0cvl6hjkkbfia6lnpk8y4shyairv"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-cc" ,rust-cc-1))))))
+
 (define-public rust-nettle-7
   (package
     (name "rust-nettle")
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9195cee498..04dda96f9e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37522,94 +37522,6 @@ async code in Rust.")
      "This package provides MaybeUninit for friends of backwards compatibility.")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-md5-0.7
-  (package
-    (name "rust-md5")
-    (version "0.7.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "md5" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0wcps37hrhz59fkhf8di1ppdnqld6l1w5sdy7jp7p51z0i4c8329"))))
-    (build-system cargo-build-system)
-    (arguments `(#:skip-build? #t))
-    (home-page "https://github.com/stainless-steel/md5")
-    (synopsis "MD5 hash function in Rust")
-    (description "The package provides the MD5 hash function.")
-    (license (list license:asl2.0
-                   license:expat))))
-
-(define-public rust-md5-0.6
-  (package
-    (inherit rust-md5-0.7)
-    (name "rust-md5")
-    (version "0.6.1")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "md5" version))
-        (file-name (string-append name "-" version ".tar.gz"))
-        (sha256
-         (base32
-          "17b2xm4h4cvxsdjsf3kdrzqv2za60kak961xzi5kmw6g6djcssvy"))))))
-
-(define-public rust-md5-0.3
-  (package
-    (inherit rust-md5-0.6)
-    (name "rust-md5")
-    (version "0.3.8")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "md5" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "0j2s8aqdkhwhy7awga2bmv5n8qq8bgy8672iha9f3y871dm6vibr"))))))
-
-(define-public rust-md5-asm-0.5
-  (package
-    (name "rust-md5-asm")
-    (version "0.5.0")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "md5-asm" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1ixmkg8j7sqy9zln6pz9xi2dl2d9zpm8pz6p49za47n1bvradfbk"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs (("rust-cc" ,rust-cc-1))))
-    (home-page "https://github.com/RustCrypto/asm-hashes")
-    (synopsis "Assembly implementation of MD5 compression function")
-    (description
-     "This package contains an assembly implementation of the MD5
-compression function.")
-    (supported-systems '("x86_64-linux" "i686-linux"))
-    (license license:expat)))
-
-(define-public rust-md5-asm-0.4
-  (package
-    (inherit rust-md5-asm-0.5)
-    (name "rust-md5-asm")
-    (version "0.4.3")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "md5-asm" version))
-        (file-name
-         (string-append name "-" version ".tar.gz"))
-        (sha256
-         (base32
-          "0gpk5647js1k084jc7pg2gji0cvl6hjkkbfia6lnpk8y4shyairv"))))
-    (arguments
-     `(#:cargo-inputs
-       (("rust-cc" ,rust-cc-1))))))
-
 (define-public rust-measureme-0.7
   (package
     (name "rust-measureme")
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 98fcd610b8..7d9a27bbc3 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -41,6 +41,7 @@
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages check)
   #:use-module (gnu packages cmake)
+  #:use-module (gnu packages crates-crypto)
   #:use-module (gnu packages crates-io)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages freedesktop)