summary refs log tree commit diff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-03-17 21:55:24 +0100
committerRutger Helling <rhelling@mykolab.com>2018-03-17 21:59:27 +0100
commit308b17f676999876bfec12841659cbfa56a652be (patch)
tree5349eea8a8145521f8cbe03d6013f6935b9292cc
parentfb6f35ba1d96072b22e767dec788446123acf29f (diff)
downloadguix-308b17f676999876bfec12841659cbfa56a652be.tar.gz
Revert "gnu: shaderc: Use more standard keys."
This reverts commit 9bc0591bc11190ac49c8ea3cf44c4903c924f6c7.
This commit broke 'shaderc'.
-rw-r--r--gnu/packages/vulkan.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 4d981416d0..bd0fb9e1ce 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -225,18 +225,11 @@ and the ICD.")
            "0b41inb1czxv3mciip0lfdxv19ccx2ys31fivfywjn2q8va1gd1f"))))
       (build-system meson-build-system)
       (arguments
-       `(#:build-type "Release"
-         #:configure-flags
-         (list "-GNinja"
-               "-DSHADERC_SKIP_TESTS=ON"
-               "-DCMAKE_INSTALL_LIBDIR=lib"
-               (string-append "-DCMAKE_INSTALL_PREFIX="
-                              (assoc-ref %outputs "out")))
-         #:tests? #f                    ; tests don't work yet.
+       `(#:tests? #f                    ; tests don't work yet.
          #:phases
          (modify-phases %standard-phases
            (replace 'configure
-             (lambda* (#:key build-type configure-flags #:allow-other-keys)
+             (lambda* (#:key outputs #:allow-other-keys)
                (let ((out (assoc-ref outputs "out")))
                  ;; Remove various lines and touch build-version.inc or
                  ;; configuring won't work.
@@ -254,8 +247,11 @@ and the ICD.")
                  (substitute* "CMakeLists.txt" ((".*--check.*") ""))
                  (substitute* "glslc/src/main.cc" ((".*build-version.inc.*")
                                                    "\"1\""))
-                 (invoke "cmake" (cons build-type configure-flags))
-                 #t)))
+                 (invoke "cmake" "-GNinja" "-DCMAKE_BUILD_TYPE=Release"
+                         "-DSHADERC_SKIP_TESTS=ON"
+                         "-DCMAKE_INSTALL_LIBDIR=lib"
+                         (string-append "-DCMAKE_INSTALL_PREFIX="
+                                        out)))))
            (add-after 'unpack 'unpack-sources
              (lambda* (#:key inputs #:allow-other-keys)
                (let ((spirv-tools-source (assoc-ref %build-inputs