summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-01 23:19:27 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-02 15:52:53 +0100
commit315c89f5ba89e18bd365846a62944820a8760b83 (patch)
tree4d9b21d867bfe7ea24f66a4bd8ac96ed73104c15
parentbb5c35820448ef9b83b59a49e94b73ae2d8f7052 (diff)
downloadguix-315c89f5ba89e18bd365846a62944820a8760b83.tar.gz
gnu: b43-tools: Update phase style.
* gnu/packages/firmware.scm (b43-tools)[arguments]: Substitute INVOKE
for SYSTEM* and FOR-EACH for EVERY, and end phases with #t.
-rw-r--r--gnu/packages/firmware.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 5f82f7c31a..d9d0c2910c 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -130,19 +130,20 @@ Linux-libre.")
                  #t))
              (replace 'build
                (lambda _
-                 (every (lambda (dir)
-                          (zero? (system* "make" "-C" dir "CC=gcc")))
-                        subdirs)))
+                 (for-each (lambda (dir)
+                             (invoke "make" "-C" dir "CC=gcc"))
+                           subdirs)
+                 #t))
              (replace 'install
                (lambda* (#:key outputs #:allow-other-keys)
                  (let ((out (assoc-ref outputs "out")))
                    (mkdir-p (string-append out "/bin"))
-                   (every (lambda (dir)
-                            (zero?
-                             (system* "make" "-C" dir
-                                      (string-append "PREFIX=" out)
-                                      "install")))
-                          subdirs))))))))
+                   (for-each (lambda (dir)
+                               (invoke "make" "-C" dir
+                                       (string-append "PREFIX=" out)
+                                       "install"))
+                             subdirs)
+                   #t)))))))
       (home-page
        "http://bues.ch/cms/hacking/misc.html#linux_b43_driver_firmware_tools")
       (synopsis "Collection of tools for the b43 wireless driver")