summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-09-27 23:47:05 +0200
committerAndreas Enge <andreas@enge.fr>2014-09-27 23:48:30 +0200
commit319e2d1736a6a85ae9c721a8516b7a2dac3c9c07 (patch)
tree9d2720e67aff5a4569334ba3bd297002a3e977d1
parent68dddcad6250a5499e55a1f1af2e2b6b7e11e355 (diff)
downloadguix-319e2d1736a6a85ae9c721a8516b7a2dac3c9c07.tar.gz
gnu: Add graphite2.
* gnu/packages/fontutils.scm (graphite2): New variable.
-rw-r--r--gnu/packages/fontutils.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 3b835760ce..5310f3cbe4 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,11 +20,14 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages ghostscript)
+  #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages xml)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu))
 
 (define-public freetype
@@ -167,3 +170,30 @@ been designed, tested, and debugged to the extent that general-purpose
 applications should be.")
    (license license:lgpl2.1+)
    (home-page "http://scripts.sil.org/cms/scripts/page.php?cat_id=teckit")))
+
+(define-public graphite2
+  (package
+   (name "graphite2")
+   (version "1.2.4")
+   (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+              "mirror://sourceforge/silgraphite/graphite2/graphite2-"
+              version ".tgz"))
+       (sha256
+         (base32
+           "00xhv1mp640fr3wmdzwn4yz0g56jd4r9fb7b02mc1g19h0bdbhsb"))))
+   (build-system cmake-build-system)
+   (inputs
+    `(("freetype" ,freetype)
+      ("perl" ,perl)
+      ("python" ,python-2))) ; because of "import imap" in tests
+   (synopsis "reimplementation of the SIL Graphite text processing engine")
+   (description
+    "Graphite2 is a reimplementation of the SIL Graphite text processing
+engine.  Graphite is a smart font technology designed to facilitate the
+process known as shaping.  This process takes an input Unicode text string
+and returns a sequence of positioned glyphids from the font.")
+   (license license:lgpl2.1+)
+   (home-page "http://projects.palaso.org/projects/graphitedev")))