summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-03 22:23:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-03 22:32:59 -0400
commit32792d2073f3096cb0710c40a7c74e5797ef0e6e (patch)
tree3cbfa9382bf7141952cc382861b8c3174cb15756
parent5a6567285780101d0ea0f6914afb656ef52daf72 (diff)
downloadguix-32792d2073f3096cb0710c40a7c74e5797ef0e6e.tar.gz
gnu: avr-gcc: Avoid referencing gcc from the top level.
Fixes <https://issues.guix.gnu.org/65716>.

* gnu/packages/avr.scm (avr-gcc): Do not explicitly refer to 'gcc'.  The
default value of the argument uses the identifier-syntax trick to delay
evaluation of gcc.
-rw-r--r--gnu/packages/avr.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 44d6e0ebbb..9c623a9626 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -46,7 +46,7 @@
     (name "avr-binutils")))
 
 (define avr-gcc
-  (let ((xgcc (cross-gcc "avr" #:xgcc gcc #:xbinutils avr-binutils)))
+  (let ((xgcc (cross-gcc "avr" #:xbinutils avr-binutils)))
     (package
       (inherit xgcc)
       (name "avr-gcc")