summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-01 16:43:22 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-01 20:52:00 -0400
commit32f001ce48eb0a0fa0f517fec605f2b7d37601f8 (patch)
tree7ec0d4434d2e47f8ee89aeb81f1d628ffab56da0
parent4f3011f21c46c2eec6fa4256bfb00052aa9512c9 (diff)
downloadguix-32f001ce48eb0a0fa0f517fec605f2b7d37601f8.tar.gz
gnu: Add h-client (again, this time with Python 3 support).
* gnu/packages/hardware.scm (h-client): New variable.
-rw-r--r--gnu/packages/hardware.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index b6d31d9485..d4e43feb06 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -13,6 +13,7 @@
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2022 Marcel Kupiec <formbi@protonmail.com>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -375,6 +376,43 @@ through the Display Data Channel Command Interface (@dfn{DDC/CI}) protocol.")
 human-readable format and checks if it conforms to the standards.")
       (license license:expat))))
 
+(define-public h-client
+  (let ((commit "63ff4a3bf9c3c3b6297091e08192d34991465431")
+        (revision "0"))
+    (package
+      (name "h-client")
+      (version (git-version "0.0a0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               ;; Use this Python 3 fork until the changes have been reviewed
+               ;; and integrated into the official Savannah repository (in
+               ;; progress).
+               (url "https://git.sr.ht/~apteryx/h-client")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0c6s96a1zmsnn7bnfhm790c1fr8sid0zdyh9mwig4y6ffn83czh5"))))
+      (build-system python-build-system)
+      (inputs
+       (list gdk-pixbuf
+             gtk+
+             pciutils
+             python-pycurl
+             python-pygobject
+             usbutils))
+      (synopsis "Graphical client for the h-node hardware database project")
+      (description
+       "The h-node project (https://www.h-node.org) aims to build a database of
+hardware that works with fully free operating systems.  h-client is a GTK+
+graphical client that is able to retrieves information on the hardware inside
+the computer it's running on, and on peripherals connected to it, and helps
+you submit that information to the h-node project along with whether the
+hardware works with a fully free operating system or not.")
+      (home-page "https://savannah.nongnu.org/projects/h-source/")
+      (license license:gpl3+))))
+
 (define-public headsetcontrol
   (package
     (name "headsetcontrol")