summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 13:53:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 14:46:22 +0200
commit338d8f36000942894a46ee8e3c3cb5a36f11f9b0 (patch)
tree9a3c1a027d3593c55950aac30b8dc836578c8d2c
parentdced765eed4b52cb71f5143825db518bcba6af6e (diff)
downloadguix-338d8f36000942894a46ee8e3c3cb5a36f11f9b0.tar.gz
gnu: Add texlive-aleph.
* gnu/packages/tex.scm (texlive-aleph): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e23dcf7fcb..0a1b1dd5cf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1330,6 +1330,33 @@ ligatures, but also offers additional control over them.")
 a given (Unicode) glyph.  It relies on Fontconfig.")
     (license license:bsd-3)))
 
+(define-public texlive-aleph
+  (package
+    (name "texlive-aleph")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/aleph/base/" "doc/man/man1/aleph.1"
+                   "doc/man/man1/aleph.man1.pdf")
+             (base32
+              "0b7dihilh2v8qcp4m8fblyc10jc5i4fhpj3pspzinag0pk66b7nb")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:create-formats #~(list "aleph")))
+    (propagated-inputs
+     (list texlive-cm
+           texlive-hyphen-base
+           texlive-knuth-lib
+           texlive-lambda
+           texlive-latex
+           texlive-plain))
+    (home-page "https://ctan.org/pkg/aleph")
+    (synopsis "Extended TeX")
+    (description
+     "This package provides a development of Omega, using most of the
+extensions of TeX, itself developed for e-TeX.")
+    (license license:gpl3+)))
+
 (define-public texlive-alg
   (package
     (name "texlive-alg")